Investigating instability

Incident Report for screenshotbot-io

Resolved

This incident has been resolved.
Posted May 09, 2025 - 00:57 UTC

Update

At this time, we believe all our systems are stable. The root cause of the issue was a misbehaving version of the CLI. We're making our server more robust to these changes and will post an incident report later.
Posted May 09, 2025 - 00:56 UTC

Investigating

At the moment we know that CI jobs and some web requests are occassional failing. We're investigating and looking for the root cause.
Posted May 08, 2025 - 21:22 UTC
This incident affected: Dashboard, API, and CI tools.