Downtime
Incident Report for screenshotbot-io
Postmortem

We had an increase in GitHub webhooks around 6.30AM Eastern time. Our webhook handler wasn’t optimized, and was writing to disk on each request which brought down the throughput on the site. This is now fixed.

Posted Sep 30, 2022 - 14:45 UTC

Resolved
This incident has been resolved.
Posted Sep 30, 2022 - 14:44 UTC
Update
We are continuing to investigate this issue.
Posted Sep 30, 2022 - 14:44 UTC
Investigating
We are investigating the source of a 15-20 minute downtime detected by our monitors. All services are currently operational.
Posted Sep 30, 2022 - 14:43 UTC
This incident affected: Dashboard, API, and CI tools.