screenshotbot.io/recorder.sh was returning an invalid script

Incident Report for screenshotbot-io

Resolved

This incident has been resolved.
Posted May 26, 2026 - 02:20 UTC

Monitoring

Starting around midnight eastern time, we started returning an invalid recorder.sh script. This is now fixed but we're monitoring for issues and pushing tooling to avoid further disruptions.

Customers who used https://cdn.screenshotbot.io/recorder.sh might not have been affected because the CDN cached the valid values.

Customers using the legacy https://screenshotbot.io/recorder.sh were served the invalid file.

If you noticed errors, do let us know so we can understand the scale of the issue.
Posted May 25, 2026 - 18:31 UTC
This incident affected: CI tools.