Server downtimes

Incident Report for screenshotbot-io

Resolved

All issues should now be resolved, please let us know if you see anything broken
Posted Apr 20, 2026 - 02:19 UTC

Identified

During a routine upgrade of dependencies, our server crashed. This brought down our primary cloud service from around 5:09 ET to 5:39 ET. During the investigation process we had a few more intervals of downtime. We're continuing with the process of deploying the upgrades, and hopefully we don't see any more downtime.
Posted Apr 20, 2026 - 01:26 UTC
This incident affected: Dashboard, API, and CI tools.